Join Us and become a Member for a Verified Badge on Discord to access private areas with the latest PS4 FPKGs.
Category PS4 CFW and Hacks       Thread starter stooged       Start date Mar 5, 2018 at 7:10 PM       214,614       898            
I will post this as a separate thread from the PS4 PKG2USB as the 2 payloads vary and it saves confusion.

Original Post: I was playing around with the ext0 mount and recreating the file structure that would be there if the pkg was installed to external storage.

There is a trick I found where if you copy the CUSAXXXXX folder from /user/app to /mnt/ext0/user/app and then unplug the hdd and plug it back in it causes the ps4 to do a repair and then the game is recognized as installed on external storage and from there there are other issues.

BUT with the great work SiSTRo has done in PKG2USB with the symlinks its a lot easier to manage with exfat and just normal USB.

So building on his PKG2USB and symlinks I modified what I was working on for the ext0 mount to work with the usb0 or usb1 and symlinks.

Downloads:
:arrow: Changlog via dbsuarez

This payload searches the entire /user/app folder and copies all installed fpkg games to usb from the system drive and creates the symlinks like SiSTRo has kindly shown us the ability to do.

If you want to target a single game not the whole folder use PKG2USB.

If you install more games just run the payload again and it will copy any new games to the USB and so on.

With symlinks you are making a link to a directory so you want to pick which USB port to have the hdd on and keep it on that same port or the links will point to the wrong directory. USB0 is what I use.

Thanks again to SiSTRo, xVortex, Anonymous, CelesteBlue!

PS4 JAILBREAK 5.05 How To Use APP2USB by seanp2500
Running PS4 Games From a USB with App2USB (5.05 Jailbreak)
AppToUSB by Stooged A Modification of PKG2USB for PS4.jpg
 

Comments

padschuko

Member
Contributor
Verified
Hi guys, I have a problem with my app2usb. Since a few days it always worked perfectly but now it shows complete every time after a few seconds but nothing is copied.

The internal drive is full and the external has at least 2 TB left but I cannot copy with app2usb. Has anyone a suggestion?

It’s working again guys. I used to insert a second usb device. Now it’s working again 🤙🏽
 

stripnwild

Senior Member
Contributor
Verified
Thank you @Samjc2007 - is there a proper way of removing a game from external storage? I found if you simply plugged it into the computer and deleted it... it causes issues if you ever have to rebuild your data base! Is there a proper way?

Also... how to move a game that was moved to external, BACK to internal?? Started getting a new error while continuing to move games to the ps4 and then running the apptousb "there is not enough free memory"

Worked fine for the first 150 games or so...but last night I attempted to move more games over (TONS of room as it is an 8TB) and one or two games/updates would move and then the error would pop up. I'd have to close it and relaunch the AppToUSB again and a few more things would move and then the error comes up again???

A/ @stooged does this corrupt and of the moves when this warning pops up and stops everything? (Or is it okay to close. Relaunch and continue)

B/ is there some sort of issue that all of a sudden started this? OR is it because I'm trying to move so many files?

Edit: ANOTHER new issues... it appears that some DLCs were not moved into the "dlc" folder on the External drive either (85% were) ? they are still on the root of the external HD? There was no "error while installing the updates" so what do do with these updates?

Example of this: Assassins Creed Odyssey - Ultimate Edition CUSA09311 Ultimate Edition All DLCs of the 17 DLCs it moved 6 somewhere?! In the PS4 "dlc" folder there is no CUSA09311 folder at all? The other remaining 11 DLCs are just left out in the root of the external HD?

Cheers
 

Samjc2007

Member
Contributor
@stripnwild Sorry on the delay, Didn't notice the Notification!

Removing a Game from the External - If you mean, You don't want it to be run from the External Storage anymore. Simply unplug the External HDD from PS4, Plug it into your computer, Find the game you want to remove & Move it to the 'Root' of the External drive. Then on the PS4 just delete the Game links just like you'd delete a regular game.

To answer your 2nd question, Now that you have it on your .pkg from the above steps in your 'Root' you can re-install it like you usually install from Game -> Package Installer. That will re-install it the Game properly into the Internal Storage.

To dig into that issue you're facing, How about you modify your App2usb.ini just to transfer that one game that it seems to keep failing at to see if it's an issue with the game or if App2USB is acting out.

Regarding the Assassins Creed - Were all 11 DLCs installed on the PS4 while you were moving it? Seems like something to troubleshoot as well! Hope the above helps - From the best of my Knowledge :)
 

stripnwild

Senior Member
Contributor
Verified
@Samjc2007 It seems any dlcs that are the size of 128 kb or the 1,600 kb etc (the really small dlc unlockers etc etc DON'T get moved when you run the AppToUSB for some reason). I noticed this on quite a few games!

So after I installed them and then ran the AppTuUSB I have to plug in into the computer and the really small files I have to make the folders (PS4_dlcs_CUSAxxxxx) manually and move them inside!
 

Orgad

Senior Member
Contributor
Hey, had a problem.

i use the ps phower for 6.72. Its included this app2usb. I used it to move all games&update&dlc to my 8tb.

i try to install some game, and the ps tell not enofe space. Before that i move all games and update and dlc to my 8 tb. what to do?

Also, it can be that i install same dlc on ps4, and thats why app2usb not move this? Is there a resolve ?
 

laz305

Senior Member
Contributor
Verified
does no one else get this glitch? when i plug my HD into the PC sometimes (most of the time) I'm getting slow transfer speeds of 20mbs but normally I should get 100mbs which sometimes happens. I thought it was my pc at first but all my other drives transfer fast with np.

I'm thinking it has to do with me unplugging it from the PS4? but there's no remove device option so what then? Do you guys power off the PS4 every time you unplug the HD?

Ok I’m now starting to want to delete games but when I do it doesn’t free up any space. Good news is when I’m not jb if I delete anything free space works. Any clue? Is there a special way to delete games from app2usb?

Wow this thing is more of a headache than anything. Remind me again why do we use it? I would of been better off using extended storage
 
Recent Articles
Sony Unveils New PlayStation Plus Games in October for PS Plus Members
PlayStation Plus members will be pleased to know Sony just unveiled the latest PS4 video game additions to their PS Plus service for October 2020 featuring both Need for Speed: Payback and Vampyr...
Win a Free PS5 Console with Doritos in PlayStation 5 Shapes EU Contest!
While currently open only to those across select countries in Europe (UK, Ireland, Belgium, Netherlands, Spain Norway, Denmark, Sweden and Iceland), Sony's latest cheesy competition offers the...
PlayStation Store Launches Games of a Generation Sale Starting Today
Headlining Sony's latest PlayStation Store Games of a Generation Sale starting today is Ghost of Tsushima with these latest digital video game deals available through Wednesday October 14th at...
Destruction AllStars, Godfall Intro & Sackboy: A Big Adventure PS5 Trailers
Since the previous videos showcasing several upcoming PlayStation 5 games, today we have some more including an Assassin's Creed Valhalla Story PS5 Trailer, Destruction AllStars Announcement PS5...
Top