Join Us and become a Member for a Verified Badge to access private areas with the latest PS4 PKGs.
PS4 CFW and Hacks       Thread starter PSXHAX       Start date Feb 20, 2022 at 4:57 AM       11,028       31      
Proceeding the updated PS4 Linux Loader Payloads, today whitehax0r (aka @razr2312 on Twitter) made available via Github a compiled and updated ArchLinux PS4 that includes some minor GUI changes and emulators for those with a Jailbroken 9.00 PS4 Console in the PlayStation 4 Scene to enjoy this weekend! 🐧

Download: ArchLinux-PS4-main.zip / GIT

Here's further details from the README.md: ArchLinux-PS4

This is a compiled and updated Arch linux with some minor personal changes more related to GUI to look better and included emulators.

ArchLinux PS4 Compiled and Updated Arch Linux for PlayStation 4 2.png

ArchLinux PS4 Compiled and Updated Arch Linux for PlayStation 4 3.png

ArchLinux PS4 Compiled and Updated Arch Linux for PlayStation 4 4.png

ArchLinux PS4 Compiled and Updated Arch Linux for PlayStation 4.png

Features
  • Parallel Downloads enabled.
  • PS4 repository enabled.
  • LightDM with autologin enabled window manager.
  • Neofetch - Show general information about this system.
  • Latest PS4 Drivers from oficial repo.
  • XFCE - Desktop Environment.
  • Steam - The ultimate destination for playing, discussing, and creating games.
  • ExFat file system support.
  • Bluez - For bluetooth pairing PS4 controller.
  • Blueberry - GUI compatible with XFCE/GTK.
  • Duckstation - Best PSX emulator.
  • Flatpak - Next generation technology for building and distributing desktop application on Linux.
  • Dolphin emulator - Nintengo Wii and Gamecube emulator.
  • Nano - Text editor.
  • Chromium - Web browser.
  • Powerlevel10k - ZSH terminal.
  • PCSX2 - Playstation 2 emulator with vulkan support.
  • Yabaouze - Sega Dreamcast emulator.
  • Hacknerdfonts - For icons inside ZSH and customized fonts for terminal.
  • RetroArch - Multiplatform emulator.
  • Minecraft Java - Because is fun. ⛏️
  • LSD - Powered LS bassically.
  • BAT - Powered CAT bassically.
  • VLC - Video player.
  • Spotify - Music player.
  • Yay - Yet another yogurt. Pacman wrapper and AUR helper written in go.
  • Zip - Compress files to zip files.
  • Unzip - Uncompress zip files.
  • P7zip - Commandline 7zip support for Linux.
  • Htop - See process and other stuff.
Mandatory requirements
  • A brain :D and a lot of patience.
  • USB|HDD|SDD 3.0
  • USB hub for connect more usb devices. (optional)
  • USB or Bluetooth Mouse and keyboard.
My PS4 Hardware
  • PS4 Slim
  • Firmware 9.00
  • Model CUH-2115B.
  • SouthBridge Baikal.
⚠️ If you have a PS4 Fat or PS4 Pro version check in the little FAQ for more details. This OS is compatible with those PS4s. Read the complete guide please. ⚠️

If you have same PS4 hardware as me you can use these files from below:
Preparing your PS4 system.
  • Make sure you are on firmware 9.00.
  • Go to Settings>Sound and Screen>Video output Settings>
  • Resolution set to >1080p
  • RGB range se to >Full
  • HDR set to >Off
  • Deep color output set to >Off
  • Then go to Setting>System>
  • Uncheck the box "Enable HDMI Device Link"
  • Uncheck the box "Enable HDCP"
Preparing your USB|HDD|SDD 3.0 Device for ArchLinux-PS4

⚠️ Highly recommended to use a USE A >=16GB USB 3.0 Device ⚠️
  • Format the USB 3.0 Device to Fat32 filesystem. You can use this software.
  • Copy and paste the bzImage, the initramfs.cpio.gz, bootargs.txt and arch.tar.xz files to the root of the USB 3.0 Device.
  • ⚠️ If you use the same initramfs.cpio.gz from my Github, this one is created by Nazky, the name of this OS should be arch.tar.xz ⚠️
  • ⚠️ If you use the initramfs.cpio.gz from psxita team, you should rename this file arch.tar.xz to psxitarch.tar.xz ⚠️
  • The total of 4 files should be on the root of your USB 3.0 Device bzImage, the initramfs.cpio.gz, bootargs.txt and arch.tar.xz or psxitarch.tar.xz.
  • Open the PS4 web browser and first jailbreak your PS4 with Al-Azif host follow the instructions on the website.
  • Then connect your USB 3.0 Device with all the needed files on your PS4, make sure to connect to the USB slot that is near from your PS4 Blue-ray Disc Drive.
  • Launch the 1GB Linux payload using the one of your trust host but I recommend to you to use this one from Sleirsgoevy because this one detects the bootargs.txt file to avoid black screen issues. I tried with other host but did not detect the bootargs.txt file.
  • When you are on the rescueshell type the following commands:
Code:
exec install-psxitarch.sh
⚠️ If you use the initramfs.cpio.gz from Nazky type the following commands: ⚠️
Code:
exec install-arch.sh
  • When the installation is done ArchLinux-PS4 is going to boot automatically, if not type the following command:
Code:
exec start-psxitarch.sh
⚠️ If you use the initramfs.cpio.gz from Nazky type the following commands: ⚠️
Code:
exec start-arch.sh
Changing the System Date and Time

The first time you boot to ArchLinux-PS4 you have to fix the time and date.

Check first the list of time zones available typing the following command on the terminal:
Code:
timedatectl list-timezones
For example mine is: America/Tegucigalpa

To set your time zone:
Code:
sudo timedatectl set-timezone Zone/SubZone
For example in my case is: __sudo timedatectl set-timezone America/Tegucigalpa

Then we will create a symbolic link to do this permanently:
Code:
sudo ln -sf /usr/share/zoneinfo/Zone/SubZone /etc/localtime
For example in my case is: sudo ln -sf /usr/share/zoneinfo/America/Tegucigalpa /etc/localtime

Now we will be enable NTP just type this on the terminal:
Code:
sudo timedatectl set-ntp true
Now just wait about 25 seconds and you will see your date and time will change automatically to your zone.

Post installation steps
  • Connect your USB|HDD|SDD 3.0 to a computer and copy again the bootargs.txt file in the root of the fat32 partition.
  • Jailbreak again your PS4 with Al-Azif host or this.
  • Select the 3 GB Linux payload from Sleirsgoevy host.
  • You will be again in the rescueshell, just type:
Code:
exec start-psxitarch.sh
⚠️ If you use the initramfs.cpio.gz from Nazky type the following commands: ⚠️
Code:
exec start-arch.sh
If you got an error like this one: "mount -o ro /newroot failed" just type the following commands:
Code:
mount -o ro /newroot
  • then: exec start-arch.sh ⚠️ If your are using Nazky initramfs.cpio.gz file ⚠️
  • exec start-psxitarch.sh ⚠️ If you are using other initramsfs.cpio.gz file ⚠️
  • and should boot now :)
TODO List
  • RPCS3 emulator - PS3 emulator. (You can try with the AppImage in their website.)
  • ProtonDB play windows games on linux.
  • Nothing more, you tell me.
Known Issues

Not sure why but every time you boot in to linux, you have to unpair and pair again your PS4 controller.

Some FAQs

What is the password for user Sony and root?


You can find that on the Desktop, you will see a text fille called Important.txt

Got black screen

Make sure your display is compatible with the 1080p resolution, if you still have a black screen try a others monitor or TV.

I want to uninstall this OS from my USB 3.0 Device

Just format your device.

How to update ArchLinux-PS4?

Just type the following command:
Code:
sudo pacman -Syyu
  • and type "Yes" if there are packages with updates.
Can I use my DS4 controller as mouse?

Yes!, you can use the touchpad of your DS4 controller.

I have difficulties to connect my DS4 controller, what can I do?

I will upload a video later.

I'm not sure about my PS4 Hardware?

You can search here or here.

Where I can find those PS4 kernels and initramfs.cpio.gz for other PS4's hardware.

Well you can download those files from Hakkuraifu Github.

Social Media
ArchLinux PS4 Compiled and Updated Arch Linux for PlayStation 4 5.png

Credits

Many thanks to:
  • theflow0
  • notzecoxao
  • fail0verflow
  • _AlAzif
  • Znullptr
  • SpecterDev
  • sleirsgoevy
  • ps4_hacking
  • frwololo
  • ChendoChap
  • Ps3ita_Team
  • NazkyYT
  • GBAtemp
 

Comments

iddqdidkfa

Member
Contributor
Verified
i tried installing hippie68's package via USB stick first- got to the command screen and entered exec install command- gave me an error due to insufficient drive space (8gb).

so i already ordered a new, bigger stick... meanwhile i tried installing the very same package (i doublechecked) via a freshly wiped and FAT32/MBR external USB drive (1TB) but i always get an instant error "couldn't mount bzimage on usb0" (left USB port)

i double checked, the very same bzimage WORKS when installing it via the (too small) USB-stick... tried another external HDD, same story... any suggestions? im on CUH1004A, Aeolia A2 btw

Edit: For whatever it's worth- i switched USB ports, ie used the outer RIGHT USB-port for the distro, as opposed to general instructions and now it's working!
 
Top