Join Us and become a Member for a Verified Badge on Discord to access private areas with the latest PS4 FPKGs.
PS4 Jailbreaking       Thread starter PSXHAX       Start date Feb 22, 2018 at 10:46 PM       68,067       222      
Status
Not open for further replies.
Following the recent PS4 Barthen Method for getting newer games running with PS4HEN, some forum members including @SkysTheLimit, @Goldenboy22 and @Picalo would like to open a discussion of theories on how newer PlayStation 4 game dumps can become playable on exploited 4.05 Firmware consoles. :unsure:

We'll use this as an ongoing discussion thread for those who'd like to share their insight and research into getting newer PS4 games with Minimum Firmware Versions above 4.05 OFW dumped and running, which according to Mathieulh is currently the BEST PS4 Firmware to be on as 1.76 is now considered outdated since the 4.05 exploit chain from SpecterDev with popular 4.05 exploit forks and experiments by IDC alongside the PS4 Exploit Host by Al Azif. (y)

Here are links to some current theories from the Barthen Method topic:
Finally, below are some other PS4 MEME and Tweets making rounds on Twitter today:
Cheers to @B7U3 C50SS and @SSShowmik for tips in the PSXHAX Shoutbox! :beer:
Discussion of Theories for Newer PS4 Games on 4.05 Firmware.jpg
 

Comments

WIENERDRIZZLE

Senior Member
Contributor
1 First game to be over +>4.05 Horizon Zero Dawn was released but without English audio. 2 then English language was added and repackaged as pkg, along with a patch that adds different subtitles.

My goal and question is, is it possible to replicate 2. Add a English to yakuza kiwami and repackage or a patch and maybe yakuza 6 later on. In theory it’s possible. But I don’t have the slightest clue on how to precede.
 

mbison564

Member
Contributor
how would we dump newer games? like me i own 2 ps4 one jailbroken one not i have lot of games old and new would like dump my new games to cause my dvds get mess up something cause of my dog take my game and make package for it run on 4.05
 

pengekcs

Member
Contributor
Verified
You need to have either a private exploit for fw ver. > 4.05, or some way to spoof the fw to 4.05. as far as i am aware the russian guy who dumped horizon just spoofed the fw requirement to 4.05. russian release of horizon was 4.07 and was not using any new features of fw 4.07 - so maybe a simple editing of param.sfo boot parameters was enough in that case.
 

SSShowmik

Senior Member
Contributor
Possibility 1. Private exploit of higher firmware which allows latest games to be decrypted from within the PS4 and make it possible to package.

Possibility 2. Method to extract encrypted game from Disc and decrypt it from outside the PS4. And packaging using Barten method.

Just my hunch
 

Macneil

Senior Member
Contributor
I think it must be a modification of the param.sfo file. Connect via pc to the console, extract param.sfo and once modified overwrite the existing one in the console, before executing it. (I don't know how to modify it, maybe it's a question of proof and error) If the author doesn't have an exploit for higher firmwares, that's one of the possibilties.

Another one could be to use the payload found in 1.76 to spoof the firmware. This payload could modified in order to make it work in 4.05

those people with a console in 1.76 could try to dump a game with a highter firmware, using that payload.
 
Status
Not open for further replies.
Top