Join Us and become a Member for a Verified Badge to access private areas with the latest PS4 PKGs.
PS4 CFW and Hacks       Thread starter PSXHAX       Start date Apr 24, 2022 at 5:24 PM       6,794       26      
Status
Not open for further replies.
Proceeding the Nobara OS Linux Distro for PS4, recently @d4rkst0rm shared a PS4 Linux Debian 11 Distro with Emulators running CEMU at 60FPS and Vulkan support complete with a demonstration video from DarkStorm PS4's YouTube Channel below. 🐧

Download: debian11_plus_emus_darkstorm.tar.xz (3.0 GB - Login: darkstorm / Password: logic) / tearch_V2_plus_emus_darkstorm.tar.xz (2.8 GB - Login: darkstorm / Password: logic) / tearch_V2_plus_emus_darkstorm.tar.xz (Mirror) / tearch_v2_english_darkstorm.tar.xz (2.8 GB)

For those interested there's also an ongoing installation topic from saya, a PS4 Linux Discord Channel for help and below is an outline of the Debian 11 PS4 Linux Distro features from Logic-Sunrise.com roughly translated:

The features of this distribution offered by Darkstorm are numerous:
  • Wine proton with Vulkan backing
  • Genesis emulator Blastem
  • Cen64 emulator of Nintendo 64
  • CEMU emulator Wii / WiiU
  • Desmume Nintendo DS emulator
  • Dolphin-emu GameCube and Wii emulator
  • DOSBox emulator for x86 supporting Tandy, Herc, CGA, EGA, VGA, SVGA, sound and DOS graphics modes
  • All-in-one NES / Famicom emulator
  • FS-UAE-Arcade Full-screen game browser for FS-UAE
  • GNGB emulator for GameBoy Color
  • Hatari emulator for Atari ST, STE, TT and Falcon computers
  • Higan multi-system emulator
  • MAME: Multiple Arcade Machine Emulator
  • Mednaffe front end for Mednafen multisystem emulator
  • MGBA-SDL emulator for the Game Boy Advance - SDL front end for mGBA
  • mupen64plus-ui-front console in console for mupen64plus
  • Nestopia emulator for Nintendo Entertainment System / Famicom
  • Osmosis-emulator Sega's Master System and Game Gear console emulator
  • PCSXR Sony PlayStation emulator
  • PSPPPS PSP emulator
  • RCPS3 PS3 emulator
  • Simple front end Retroarch for Libretro library
  • Ryujinx Switch emulator
  • Stella emulator of Atari 2600 for SDL and X Window System
  • Virtualjaguar cross-platform emulator of Jaguar from Atari
  • VisualboyAdvance advanced and complete Game Boy emulator
  • Yabause Saturn emulator
  • Yuzu Switch emulator
  • Xemu Xbox emulator
  • Zsnes emulator for the Super Nintendo / Super NES
  • DuckStation
  • EmulationStation
  • Heroic Launcher (Epic Games) with Proton support
  • Steam Linux runtimes
  • LUTRIS
  • Kodi and VLC for movies

:arrow: Update: Also available is PS4 DarkStorm teARCH v2 according to tralala, who states the following roughly translated:

"My sunriser friend darkstorm informs me by private message of the availability of a new version of teARCH, which according to him is probably the most suitable distro for emulators.

teARCH v2 is therefore now available, and it has arguments, a boot in less than 10 seconds on a USB SSD 3.1 key, a very light desktop part to keep maximum power and memory for emulators, in short, a very suitable distro to this area for the PS4."

PS4 LINUX SEarch running YUZU SWITCH emulator at 30 FPS with VULKAN support
PS4 LINUX TEarch running DOLPHIN at 60FPS with VULKAN support
PS4 LINUX TEarch running CEMU at 60FPS with VULKAN support
PS4 LINUX TEarch running PPSSPP (PSP emulator) at 60FPS with VULKAN support
PS4 Linux Debian 11 Distro with Emulators via DarkStorm Arrives.jpg
 

Comments

Olympia01

Member
Contributor
Verified
@d4rkst0rm
Thanks for the English version, but it appears to be an earlier version than the French version that doesn't support wifi (did install French version and that did).

Don't suppose you have the updated version in English please.

Edit: Sorry my bad. Managed to change to English, but need to play around as had wifi now lost it 😊
 

hazytreats

Member
Contributor
Verified
i tried installing the english version tearch v2, on cuh-7015 with Belize kernel 4.14.93 and psyche initramfs. I found that after installing, if i type "resume-boot", it doesn't do anything and had to power cycle the ps4.

ctrl-alt-f1/f2/f6/f12 didnt change anything, but after restart and typing exec start-psxitarch.sh got the system to boot into a black screen with a mouse pointer.

i can move the mouse pointer all around the screen but cant do anything else. had to power cycle again. maybe the kernel is wrong, i'll try later versions. anyone else experience this? by the way 4.14.93 is most stable so assumed that was correct.
 

pcfreaxxx

Member
Contributor
Verified
I've tried to install Debian on cuh-1116a internal HDD. Hippies initramfs.cpio.gz and codewrench's bzimage 5.15.15 in user/system/boot and Debian 11 renamed to psxitarch.tar.xz in user/system/linux

When i start 1gb Linux loader it's stuck at this point:

PXL-20220509-094617148-MP.jpg
 

manczyslaw

Member
Contributor
I have the same fat model as you and unfortunately you can't use nazky initframs it only works with slim ps4's hdd, usb install works fine. If you want to install it on fat, you have to use initframs from old hdd install metod for those models here on psxhax (just grab it from the linux 5.05 loader rar, don't use the bzimage from there it's old).

Keep in mind that the folder linux become read only sometimes so you need to delete it from psxitarch distro on usb that has hdd mount app, also set files to write able if it won't boot anymore (it's kind of annoying, distro can't write anything then). I hope nazky will make initframs that works with fat model because wifi is not working on my slim (tried every option available).
 

spirosvii

Member
Contributor
Hey guys, i'm trying to install the distro but i get an error mesage. I tried the all three alternatives bzImage like by codedwrench (Beta), by ps4boot & mircoho, bzimageAeolia psxita through any 9.00 Option > Linux Group > Whos_That_Southbridge

Failed to load file: bzImage.

Paths checked:
/mnt/usb0/bzImage
/mnt/usb1/bzImage
/mnt/system/boot/bzImage

thanks anyway!
 
Status
Not open for further replies.
Top