Join Us and become a Member for a Verified Badge to access private areas with the latest PS4 PKGs.
PS4 Guides and Tutorials       Thread starter PSXHAX       3,043       0      
Status
Not open for further replies.

PSXHAX

Staff Member
Moderator
Verified
Below is a guide to the PS4 NOR Chip dumping process via TheDarkprograme, to quote:

So here's a topic a close friend of mine AlphaHack made on his process and a bit more info on dumping the PS4 NOR, as follows:

PS4 NOR Chip Dumping Process

Download: [B]PS4 NOR Chip Dumping Process.pdf[/B]

First of all, this document is not intended to be a tutorial. It is just a narrative of the process I recently went through on dumping the PS4 NOR chip, keep it documented and share the experience with others.

I would like to thank the precious help from TheDarkProgramer and also Cfwprophet, and say that without their help it would have been much hard to me to accomplish the task.

It all started with the purchase of a BLOD PS4 which I took to a repair house and they got it fixed. They guys there told me one interesting thing about the BLOD issue that I could not find in forums.

The BLOD can be result of many things, but what it matters to get it fixed is whether when you turn the PS4 on it gives you 3 beeps or turns on with no beeps, just the blinking blue light.

If your console only blinks blue light after it’s turned on, they it can be fixed by reballing.

I also would like to point that some people think that reballing is the same thing as reflow (this is not intended for you devs, I know you now the difference). So reballing is the process of removing the chip, clean the solder left on the chip and on the motherboard and then doing the soldering again; while reflowing is just to heat up the chip expecting to melt the solder underneath it (which most of the time doesn’t work).

So, for those of you that have a BLOD PS4 and it is not beeping when it boots, just take it to a professional reballing repair shop and you’ll have it back.

Ok, the PS4 used is a US black model, serial number MB076678134 and motherboard SAA-001.

ANmmdN0-1.jpg

Reaching the NOR chip MX25L25635FMI-10G my first impression was that the task would be quite hard since I don’t have much experience in desoldering such SOIC chips.

rSaEmO0-2.jpg

For desoldering I followed TheDarkProgramer tip not to use heat gun cause it could damage the motherboard. So I used my simple soldering iron and watched some youtube tutorials on how to remove SMD's.

The desoldering process was quite long and the tools I used were:

  • Soldering iron;
  • Liquid flux;
  • Desoldering wire wick.
X2XJ6vE-3.jpg

After desoldering, I started soldering the wires to the NOR.

1Rrku1e-4.jpg

Since I have a Raspberry Pi I decided to go with that, instead of using Teensy++ 2.0 board. Soldered the other end of wires to the Raspberry.

S9Dxj6z-5.jpg

The finished work resulted in this:

BC0jI6w-6.jpg

Now it would be showtime. I used Jaicrab's tool JaiSpi v1.0, but when I tried first to read the chip I got my first error: form Terminal: “Error opening device /dev/spidev0.0”.

For those who try and get this error is not related to the NOR chip or with the tool. The problem was that SPI interface was not enabled on my Raspberry Pi, so fixed by going to raspi-config and set it enabled by default.

My second attempt I could establish a connecting but was not getting the correct info on the chip. Actually I got ID: 0xC33019 unknown! for the chip info.

But I tried a third attempt and this one I got the correct info from the chip: ID: 0xC22019 MX25L25635.

But I noticed that whenever I tried a new read from the chip it would alternate between ID: 0xC33019 unknown! and ID: 0xC22019 MX25L25635. But since I was getting the correct info too I decided to make the dump. In fact I did 10 dumps. Each dump took 30s to complete.

Now it was time to check the dump with Cfwprophet’s PS4 AC1D Flash-Tool. After checking each dump with the tool, I was getting 5 errors out of 36 and then I got worried, because I thought that the connections and soldering was fine.

But then I decided to try to make a better connection between the chip and Raspberry Pi in order to get a 0 error dump.

So next step was to build my ow PCB and get the NOR chip soldered to it and I came up with this drawn by hand:

mCsZoeJ-7.jpg

I also wanted to use better wires and use connectors instead of soldering them directly to the board GPIO. So the final package was this:

Yxk78D1-8.jpg

This time I noticed an improvement to the connection because read to the chip I wasn’t getting the unknown error anymore. Each attempt was 100% successful getting the chip info correctly. So I would not recommend, if you want try to dump the NOR chip, not to use wires to the chip directly. It is worth the time of doing your own PCB.

Dumps finished, time to check them with Acid Tool and for my surprise... I got again on all new 20 dumps the same 5 errors I got on my previous 10 dumps...

Then it happened that I talked to Cfwprophet telling him about the errors I was getting and he told that I should have read his ReadMe.txt file before, because in that file he has explained why that happens for now, but my dumps were fine (Thanks for being patient with me Cfwprophet!!).

Dumps checked and fine for now, I felt like mission’s accomplished and then I could put the PS4 al together and see if it would work again since I was working on a recovered BLOD console.

But before packing it all I changed the thermal paste and used Arctic Silver 5 and used a good amount of it..

Time to start up the PS4 and then... BLOD again... Then I restarted again and BLOD again. After a few moment of frustration I remembered that a long time ago I read that when it comes to thermal paste thou shall not use no more than a blob the size of a bean, and comparing to the amount I put on the PS4 it was like 3 times the size of a bean and as I read back then this could invert the process of the theorem paste and instead of cooling it would increase the heat...

Then I thought that could be the problem and so I opened the PS4, removed all the thermal paste that had gone over the main chip (sorry guys, I got so pissed of with me that forgot to take a picture of the mess I did), and applied a decent and correct amount of Arctic 5.

And to my happiness the PS4 turns on and its working like a charm now.

Well my friends I think that reaches the end of this documentation. Hope it may be useful for those who will try for the first time. Take care kids!!!

xXx AlphaHack xXx
“Nothing Is True Everything Is Permitted”.

:arrow: Update: Hey I decided to make things a bit easier for those who never opened their PS4 and has no experience in dumping the PS4 and posted some videos on YouTube. Here are they:

PlayStation 4 Teardown

Desoldering the PS4 NOR Chip

Cleaning the PS4 Motherboard

How to Dump the PlayStation 4 NOR Chip
 
Status
Not open for further replies.
Top