Join Us and become a Member for a Verified Badge on Discord to access private areas with the latest PS4 PKGs.
PS4 CFW and Hacks       Thread starter PSXHAX       Start date Oct 17, 2019 at 1:01 AM       47,126       105      
Since his YouTube Issues PlayStation 4 homebrew developer @MODDEDWARFARE returns releasing on Twitter a PS4 Patch Builder application used for building modded Update Packages (PKGs) alongside a video tutorial on his YouTube Channel! :pumpkin: 🦇 🌕 🧛‍♂️

He states the new PlayStation 4 Patch Builder tool makes it both quicker and easier to create / build modded update PKG files for PS4 games than the previous update package methods. 🧟‍♂️ 🧟‍♀️ 🍖🦴

Download: Patch Builder v1.3.2.zip (37.9 MB) / RAD Video Tools

Spoiler: Depreciated

For those interested, some previous PKG methods include Adding PS4 Game Updates in Packages, a PS4 PKG Repackager for FPKG Updates, another PS4 Fake PKG Update Repackager Script and handling PS4 FPKG Game Updates with Mismatched Title ID / Region Patch.

Check out his latest PS4 Patch Builder tutorial video below:

PS4 Patch Builder Release/Tutorial
Installing PS4 Games, DLC & Updates (PS4 6.72 Jailbreak)
Installing Retail Updates on a Jailbroken PS4 (6.72 or Lower!)
PS4 Patch Builder for Building Modded Update PKGs by MODDED WARFARE.jpg
 

Comments

milh0use

Member
Contributor
Hi, i'm getting this error when trying to generate a Patch for a PS2-PS4 Classic Game:
Code:
[Debug]    2021-10-07 20:55:36 Create image Process started.
[Error]    param.sfo: Param Application Type: It must be Freemium App (=app pkg's value).
[Error]    2021-10-07 20:55:38 Create image Process finished with error(s).
Is there any solution? Thanks!
 

Art2Fly

Member
Contributor
Verified
1.3.2 does not work, A/V blocks it anyway.
1.3.1 gives me:
Code:
[Debug]    2021-10-29 20:51:50 Create image Process started.
[Debug]    nptitle.dat: NP Title file.
[Warn]     The latest QA passed package file is not specified although Application Version is 01.50. Delta patch feature is disabled. Make sure that it is intentional.
[Error]    The following combination of Volume Type/Storage Type is not allowed or not supported. (app:unknown, patch:digital25)
[Error]    2021-10-29 20:51:51 Create image Process finished with error(s).
 

mary skeltor

Member
Contributor
Verified
I tried to create the modded-update of lost judgment, but no matter what I did, I got the following error and I can't proceed.
"Failed to Build GP4 Project File :(" The log reads as follows:
Code:
[Error] Could not open or read project file. (H:\modding\custom\Patched.gp4)
I tried to use fake pkg gen, but it doesn't work because the version of the tool is low. "The format of the package file is newer than that supported by this tool. The tool must be updated."
Is there any other way?

Update: I erased everything and extracted it again, so it worked. Thank you for the tool.
 

:fire: Latest Help Topics

Top