Join Us and become a Member for a Verified Badge to access private areas with the latest PS4 PKGs.
PS4 News       Thread starter Havok10       6,104       15      

Havok10

Senior Member
Contributor
I know there are a few disc based VR games. (Skyrim etc.) is there anything else we can do with the PSVR on a 4.05 system??

Is it feasible to upgrade to the 5.50 BETA install some PSVR games and then downgrade back later?

Someone said there is a PSVR firmware update, that is incompatible with v4.05. Are PSVR firmware updates manditory or can you stay on an earlier version?
 

psxmod

Senior Member
Contributor
Verified
My psvr is on 3.10 and not working with 4.05 system firmware.

I think psvr 2.50 is the last firmware compatible with 4.05 system firmware
 

TheEqualizer

Member
Contributor
I posted this on a similar thread, but will do it here as well since this one is specifically for this info:

I obtained mine from Walmart at the beginning of this year. It was the first generation PSVR and was on clearance for $170 to make room for Gen 2 model that comes with Skyrim VR. This Gen 1 model was comboed with Gran Turismo racing game. I got lucky as every time I was going to hook it up to my PSPro (v5.0+ fw) and give it a spin, I got sidetracked. Fast forward a month, it has only been connected to my 4.05fw PS4. The fw version on the PSVR is 2.50.00.00. I looked it up on Google and it seems that:
  • PS4 5.00fw+ >= PSVR 2.90fw
  • PS4 4.50fw = PSVR 2.40fw
  • PS4 4.05fw = PSVR 2.00fw
Mine was preloaded with 2.50.00.00 which seems to be a greater than 4.50fw update. YET, it still works with 4.05 games and doesn't prevent me from playing them!

So far, I've heard v3.10+ fails to work but I am unsure about the versions between it and 2.50. It would be nice to hear from others what version they have and if it works or not.
 

stooged

Developer
Senior Member
Contributor
if you load the hen payload then go into the Debug Settings then look for PlayStation VR then go into PlayStation VR Version Information it will show you the current version on your ps vr and the required system software version to use the vr.

mines 3.10 and requires system 5.00
 

stooged

Developer
Senior Member
Contributor
Yeah i left my vr on my other ps4 that gets updated and i let the vr update like a noob lol now i gotta source another vr black box or whole kit
 
Top