Join Us and become a Member for a Verified Badge to access private areas with the latest PS4 PKGs.
Not open for further replies.
Since the previous PSXITArch Linux v2 revision, the PSXITArch Team (Ps3ita_Team on Twitter / Ps3itaTeam on Github / PSXITA Ko-fi / PSXITATeam Patreon <3) released PSXITArch v3 which is a PS4 Linux Distro for Jailbroken PlayStation 4 consoles! 🐧

For those just joining the PS4 Scene, below are some related articles (sorted by date with the oldest first):
Here's further details on PSXITArch v3 from their official release page at, roughly translated:

We are happy to present Psxitarch v3, a linux distribution for PS4 designed to be light, fast and low on resources (it occupies less than 370mb of ram)

Before we begin we would like to thank those who supported us on patreon and in fact made the realisation of this distro possible, a big thank you to Zecoxao and Z3R0, thank you guys!

Thanks also to eeply, flavio, jesus who supported us via ko-fi and allowed us to pay for the hosting service.

Ok, let’s get started.

  • System updated
  • Mesa drivers updated to version 22.2.0_devel.
  • Ability to switch from Vulkan (ACO) to Vulkan (LLVM) on the fly.
  • Script to configure TearFree.
  • Ps4fancontrol integrated into the distro. It is started automatically at distro start-up and sets the desired threshold temperature. When shutting down the console or returning to ORBIS OS it temporarily resets the threshold to the default threshold. It is therefore not necessary to remove the power plug to reset the fan.
  • Script to easily set the system language.
  • Script to set the keyboard layout for xorg and vconsole.
  • Script to mount the user partition of the PS4’s internal hdd if your kernel supports it.
  • Application menu updates automatically after installing or removing an application.
  • Keyboard shortcuts to enable and disable the video signal. In case of a black screen after turning off/on the TV or changing video source or removing the hdmi cable or for any other reason you can get the video signal back by pressing the key combination ALT+F11 and ALT+F12. In case it doesn’t work you can use the combination ALT+F1 and ALT+F2.
  • Script to enable and disable the desktop.
  • Time is updated automatically after connecting the console to the network.
  • Possibility to change the colour of the PS4 LED.
  • By pressing the key combination ALT+F6, a screenshot can be taken. The screenshot will be saved in ~/Screenshot.
  • Installation script now will correctly aligns partitions (Thanks to Hippie for bringing this to our attention) and warns you if you haven’t formatted your USB device correctly.
  • Automatic login.
  • And if you are a expert user and you know what a icc cmd is, you can send icc cmd with a application we included named “send_icc_cmd” (for use it you need create a device node to control ICC with sudo mknod -m 0666 /dev/icc c 0x49)
  • :alert: Use the app just if you are sure what are you doing, you can brick your PS4 if you send the wrong icc cmd.


  • duckstation (PS1, runs great, some games run at more than 4k)
  • dolphin-emu (Gamecube, Wii)
  • mupen64plus (Nintendo 64)
  • ppsspp (PSP)
  • retroarch (Multi-Emu, only a handful of cores are pre-installed but you can install the ones you want by going to the ‘Online Update > Download Cores’ menu)
  • steam (if you need just launch a game from steam, you can save a lot of ram selecting from menu “View” -> “Small Mode”, close Steam and select from menu application “Steam (No Browser)”
  • cemu (Wii-u, performance is obviously not great but on PS4 PRO you can play a handful of titles decently)
  • wine
Windows Manager: jwm
Web Browser: chromium
File Manager: pcmanfm
Text Editor: leafpad
Archive Manager: xarchiver
Network Connection Manager: networkmanager
Bluetooth Manager: blueman
Image Viewer: gpicview
Video/Music Player: vlc
Terminal Emulator: lxterminal, xterm
Partition Editor: gparted
Audio Device Manager: pavucontrol
PDF Viewer: epdfviewer
Wine (Run windows applications)


The installation is identical to the previous version, do NOT use any other initramfs use the one below (unless you want to install the distro on the internal hd, in that case remember to copies the edid and the eap key to the distro), as for the bzimage (kernel) take the one you prefer the important thing is that it is not a version lower than 4.15.

⚠️ WARNING: the USB device you will use for the installation will be completely formatted, all data on it will be deleted!


  1. Format the USB device in FAT32 (NOT EXFAT!), the usb device must have only one partition and the partition table must be mbr (MS-DOS (FAT32)). MBR remember this, it is essential.
  2. If you have connected the PSVR unplug it, also remove the processor unit (PU), keep only the PS4 connected to the TV.
  3. Go into the ps4’s audio/video settings and set the resolution to 1080p.
  4. Go into system settings and disable Enable hdmi connection and Enable hdcp
  5. Copy the files bzImage, intramfs.cpio.gz and psxitarch.tar.gz to the root of the USB device.
  6. Plug the USB device into the PS4.
  7. Connect your mouse and keyboard.
  8. Start the VRAM 1GB payload (after installation you can use the one you prefer). If you start the payload from the PC make sure to use miraloader NOT binloader on the PS4.
  9. After a few seconds the PS4 should reboot, wait until the rescueshell appears.
  10. Type exec to start the installation of psxitarch linux.
  11. Wait, you should see a long list of files being copied to the USB, when it finishes (after about 10/15 minutes with a ssd) the distro should boot automatically. If it does not start, type exec, sometimes you need type this twice. From the next reboot the distro will boot automatically.
  12. Enjoy.
The distro does not require you to enter your username and password at login, but you will need them in case you want to obtain root permissions:
  • username: psxita
  • password: changeit

The problems are the usual known ones, not related to the distro but to the kernel.
  • There is a problem that has been present since the very first kernels, when an ethernet cable is connected to the console the consumption of one of the CPU cores jumps to 100%, to remedy the problem (if you don’t need a connection) remove the ethernet cable.
  • Some monitors and TVs with strange resolutions may give problems and display nothing on the screen, if you have the chance try another TV.
  • If the screen goes black because you have turned off the TV or changed video sources or for any other reason, try pressing the key combination ALT+F11 and after a few seconds ALT+F12, if that doesn’t work try ALT+F1 and ALT+F2.
  • If you notice video glitches while using the Vulkan drivers, try switching to a different compiler (in the application menu under “System” you will find a script that allows you to change the compiler from ACO to LLVM), after changing the compiler restart the application or game.
  • The wifi/bt drivers are buggy, the wifi and/or bluetooth card might not be detected or crash, in case try restarting the console, disable the network and launch linux using the cache. If that doesn’t work unfortunately there is little you can do, you have to hope that someone will fix the drivers.
  • In rare cases usb devices (mouse, keyboard, ..) may not be detected, in which case restart the console.
:note: At the time of writing, mesa versions greater than 22.2.0-devel have problems that make Vulkan with the ACO compiler not work, at the moment we have not found a solution, no promises, but we will keep looking into it.

On that note, we would like to sincerely thank zerobou for finding the latest version of mesa working with both compilers and for the patch for PS4 PRO which fixes a problem in the latter (and some earlier versions).


As always we would like to thank and remember all the people who over the years brought linux on PS4 to the level it is today:

Marcan (without him linux on PS4 probably wouldn’t exist), eeply (we won’t have support for PS4 PRO, for PS4 SLIM, audio via HDMI and much more), masterzorag (maybe we’ll still be relegated to radeon drivers), Valeryy (we won’t have support for Baikal), Zer0xFF (no support for internal hdd on Belize), codedwrench (without him no kernel >= 5. 15), Mircoho (he make kernel ports, gentoo based distro and test a lot of stuff), zerobou, hippie, Valentinbreiz, sleirsgoevy, shuffle2, flatz, CelesteBlue and all the people who have been updating video drivers month by month, releasing distros and keeping linux alive. Thank you all!

And big thanks to Pippo (Airart) ;)

Spoiler: Related Tweets
PSXITArch v3 PS4 Linux Distro for Jailbroken PlayStation 4 Consoles.png


I'm losing my hair trying to find out how to transfer a 6.33GB psxitarch.tar.gz file to a Fat32 external HD. I've tried adding it to a archive split into several parts but as soon as its rebuilt to 4GB it stops. Is there something I'm missing? Why isn't this covered in the installation instructions?
I can confirm the MD5 (9B3514AE14F43A1605F514481C97AF96) posted is for psxitarch.tar.gz with the following file size: 2.93 GB (3,154,861,750 bytes).

Those getting an erroneous 6 GB file may want to try downloading it with a different browser, etc.
that's wild im now been takin to a mega link using edge, ive downloaded the file 3.5 times today with a file size of 6.3gb on chrome & opera but could not do anything with it.

I'll download the 2.94gb from chrome and struggle to install it for different reasons thank you

Ive had linux installed but some distros no internet. Finding settings that work on my pro is problem some thank you for help
Am I the only one who has never been able to get anywhere when pressing install linux from a menu? Always out of memory no matter what I do. Clean cookies etc. I am on a ps4 pro. I have not seen the next screen ever. Tried different homepages. Any more suggestions what to do to get to the next step?
I have had loads off issues key thing is to get the correct bz image, i think you need the one applicable to your pro system. Ive tried to get this running multiple times experiment and be prepared to revisit multiple times
Its now loaded on my ps4 no wifi atm but its progress
Not open for further replies.