Join Us and become a Member for a Verified Badge to access private areas with the latest PS4 PKGs.
PS5 Jailbreaking       Thread starter PSXHAX       Start date Mar 28, 2022 at 12:09 AM       27,761       56      
Status
Not open for further replies.
Earlier this month developer @KIWIDOGGIE revealed on Twitter that unlike PS4 the PS5 utilizes (3) stages of security: Webkit (Userland), Kernel level and some additional memory (Hypervisor codenamed Hylonome / VM) protections... while over the weekend developer @zezu420 (aka Znullptr on Twitter) confirmed, "there are going to be more levels of 'jailbreak' for PS5 than for PS4" stating that, "others are working on it as well and maybe there will be disclosure 'soon'." :love:

Since the PS5 Root Keys Were Obtained privately, a PS5 4.03 Kernel Build String alongside PS5 Webkit Execution: 4.03 ROP Userland Exploitation was publicly released in the PlayStation 5 Scene with developer Znullptr noting, "That is the firmware I tested the exploit on, others are vulnerable" referring to 4.03 PS5 OFW (3.20 now included also) as Sony just pushed live 5.00 PS5 OFW last week. :unsure:

Security Engineer @CTurt also dropped some unspecific hints via Twitter in recent months pertaining to his HackerOne PlayStation Bounties, with the related Tweets included HERE for those who missed them. :ninja:

In addition to adding PS5 support to a PS4 emulator called PSUV (additional projects at EmuDev.org), speaking on PS4 exploits, the ETA WEN crowd and related frustrations developer Znullptr makes a valid point stating, "everyone is still all about 9.03 even tho 9.00 was just released covering 99% of machines in existence" referring to the pOOBs4 Jailbreak Exploit that hit the PlayStation 4 Scene only a few months ago. o_O

<3 Being tired of contracting and bounties, Znullptr (aka dmiller423 on Github) is currently seeking donations for hardware and further testing... those interested in lending a hand can do so directly to David Miller via:
Below are the related Tweets, and always verify the information matches prior to donating in order to avoid potential scammers:

Spoiler: Related Tweets
Znullptr on PS4 PS5 Jailbreak Exploit Development, Seeking Donations.png
 

Comments

Saito1227

Member
Contributor
Verified
let's just hope that ps5 jb would be higher than 4.03 otherwise there is not point of jb it in the first place if we can only play ps4 games on it because most ps5 games like dying light 2, horizon forbidden west and also elden rings required higher version than 4.03, we don't know yet if backport is possible.
 

Cybereu

Member
Contributor
Verified
If there's a jailbreak for 4.03 I will play some VR games that were enhanced on PS5, and there's some room for devs to work on a Linux port too.
 

PSXHAX

Staff Member
Moderator
Verified
Updated the OP and PS5 Userland Exploit topic with these as well:

So it looks like [PS5] 3.20 will also be supported for userland exploit, should be added to repo sometime this week incase anyone was interested in poking at it security and didn't want to upgrade to 4.03.
 

xxboarderxx

Member
Contributor
Verified
@blimblim04 A few posts back, you had mentioned that anything beyond CFI-1100A would be useless. I can tell you I just bought from the store a CFI-1115A 01X and the system software is 21.02-04.03.

Were you meaning that it is useless for something else? I think this software version is jailbreakable (once they have kernel exploit) right?
 

blimblim04

VIP Member
Senior Member
Contributor
Verified
@xxboarderxx
I can confirm $ony started to update those models to latest firmware version long time ago, also I'm talking about USA release. Another region is another history and I have no idea about those consoles in there. Anything on 4.03 or below is good, but I wont take the risk to buy those model and get 4.50 or beyond. Unless you have a spare console on lower firmware.
 

xxboarderxx

Member
Contributor
Verified
Ok well I have a US release but anyway I'm just sharing what I have and getting clarification on what you had said.

My philosophy is, if you can get your hands on a PS5 regardless of the software version, you should as they are still elusive. I was lucky to get a pre-order back in Nov 2020 but sold it for double. It took me over a year to get another one from any Bestbuy that is around me.
 

jamesblond007

Senior Member
Contributor
Verified
If you are online with Sony update enabled, Sony will update your firmware given the chance its a given

If the newer consoles have differing components that's something we had not considered

However you would think unless there has been a change of components all PS5s below a certain firmware would be susceptible to the same exploit not PS5 model specific but time will tell
 
Status
Not open for further replies.

:fire: Latest Help Topics

Top