Join Us and become a Member for a Verified Badge on Discord to access private areas with the latest PS4 FPKGs.
PS4 CFW and Hacks       Thread starter PSXHAX       Start date Nov 7, 2018 at 1:53 PM       48,863       105      
Proceeding the PS4Cheater revisions, PS4 SaveData Decrypting Tools and his last update PlayStation 4 homebrew developer ChendoChap committed a PlayStation 4 Save Mounter utility to Github today for Windows utilizing ps4debug.bin with details below! :D

Download: PlayStation 4 Save Mounter.exe / GIT / PS4 Save Mounter PC Client Source Code forked by tunip3 / Fork by D-Pyro / Playstation.4.Save.Mounter.exe / ps4debug.bin (For 6.72 Firmware) / Playstation-4-Save-Mounter_v1.6.zip (PS4 Save Mounter for 6.72 with ps4debug payload) / GIT Fork by GiantPluto / Updated Offsets for 7.00 Testkit / Playstation-4-Save-Mounter_v1.7.zip (PS4 Save Mounter for 7.02 with ps4debug payload) / GIT Fork by Joonie86 / PS4 Save Mounter for 7.55 / GIT Fork

To quote from the README.md: PlayStation 4 Save Mounter

Summary


This program allows you to mount save data as READ/WRITE

Prerequisites
  • PS4 5.05
  • FTP Client
Instructions
  1. Load ps4debug
  2. Start a game
  3. Load FTP
  4. Open the tool
  5. Enter the ip of your ps4 and press click 'Connect'
  6. Click 'Refresh Processes' and select your game in the combobox
  7. Click 'Setup'
  8. Click 'Find Dirs'
  9. Select the save you want to mount in the combobox
  10. Select the mount permission in the combobox (default is READ ONLY)
  11. Click 'Mount'
  12. Your save is now mounted in /mnt/pfs/ & in /mnt/sandbox/{title}/savedataX
  13. After you're done copying/replacing files click 'Unmount'
  • Some games use another save format, they have an sce_ prefix in their name. they won't show up as search results
  • This can probably be patched but I was too lazy
Here's a workaround:
  1. go to /user/home/{userid}/savedata/{titleid}
  2. make a copy of the sce save: 2 files, the bin file(96KB), the sdimg file
  3. rename them
    "sce_sdmemory.bin" -> "temp.bin"
    "sdimg_sce_sdmemory" -> "sdimg_temp"
  4. go to /system_data/savedata/{userid}/db/user and download the database.db file
  5. open it with an sqlite editor
  6. add a new record in the savedata table
  7. fill in the data and you're done
  8. replace the original database with the newer one
  9. Click 'find dirs' again, it should now add a temp entry in the combobox
  10. proceed as usual
  11. go to /user/home/{userid}/savedata/{titleid}
    • delete the original sce_sdmemory.bin and sdimg_sce_sdmemory
    • rename temp.bin to sce_sdmemory.bin and temp to sdimg_sce_sdmemory
  12. replace the modified database with the original one
  13. you're done
Authors
Acknowledgments
PlayStation 4 Save Mounter Demonstration via Sc0rpion
PlayStation 4 Save Mounter Homebrew Utility by ChendoChap.jpg
 

Comments

Jason Tod

Member
Contributor
Does anyone how to fix the error after the Setup function is clicked? I keep getting the message "Unhandled exception has occurred in your application"
 

Makhdum

Member
Contributor
Verified
@kingman12170 how did you solve that "unhandled exception" error
@Breheim @Jason Tod did you get any solution yet?

I have the same error, went through the whole thread and tried the methods posted by @lotus78 and & @dark90

I get the same error with or without laoding the FTP.

Had it done by using save mounter V1.5 and sending the payload (ps4debug.bin) using the send payload option provided in v1.5. Unfortunately "SAVEDATA0" folder is missing even after successfully mounting the save.
Game : Ashes Cricket
Title id: CUSA09663

Trying to update teams.
 

Peppins

Senior Member
Contributor
Verified
Hi, anyone have tryed with skylanders imaginators? I mount the saves but i can't find them. I can find only a folder in the mnt/pfs that have inside a file called "SYS-DATA.sav", that will be always the same, like the tool don't work. Also i can find the folders (savedata0) even if i don't run the save mounter. Anyone can help?
 

Gamerig

Member
Contributor
Verified
Hi whenever I try to hit Setup after it succesfully connects to the p4 ip, the windows software just hangs and shows not responding.

FTP via ftp client is working fine and also the save mounter tool shows connected succesfully. Pressing Setup messes it up.

What am I doing wrong?
 

Peppins

Senior Member
Contributor
Verified
The function of readonly of 1.4 version work very well. If you first load a savegame in the game, then mount it as readonly, everything you do in the game isn't saved to that save. When you return to game menu, you can unmount it and you will have the savegame back again.

This readonly function it's awesome, and it what i'm looking for, BUT if you mount the save before the game loaded it, it say it's damaged.

Anyway to add a different function to set some saves to readonly but that the game can read them and not write on them? Isn't useful right now that you need to mount/unmount manually each time from pc xD
 

DaRKeN58

Senior Member
Contributor
Verified
Stuck the program when click in MOUNT :( after of this, the PS Button dont work and have reboot holding down the POWER button :(

PS4 Pr0 6.72
 

:fire: Latest Help Topics

Top