Category PS4 CFW and Hacks       Thread starter PSXHAX       Start date Jan 10, 2020 at 2:03 AM       19,529       39            
Following the PlayStation 4 Linux Scripts, previous PS4 Gentoo Linux Dev Updates and PS4 Linux Loader Baikal Chip Support today developer @iguy0 let us know he migrated Valeery's Baikal Chip kernel patches to the new Gentoo 5.3.7 kernel by PS4Gentoo! 🐧

Download: ps4-kernel.zip (10.4 MB - Compiled) / PS4Linux-Kernel-master.zip / GIT

And from the README.md: PS4 Linux

PS4-sources 5.3.7 + Baikal patches (should work for most PS4 versions)

In short this is the combination of https://github.com/ps4gentoo/ps4-linux and https://github.com/Ps3itaTeam/ps4-linux/tree/ps4-4.14.93-baikal.

It works phenomenally well on my PS4. I use PSXITA v2 with this kernel. Unfortunately I haven't tested on other versions since I only own a 2115b, but as far as i could tell from the patches it should work on ALL* versions now.

You are more than welcome to confirm this by creating an issue with the model and behavior.

Enjoy!
  • = untested
Download: PS4 Gentoo Theme.rar (14.6 MB)
Download: bzImage (5.9 MB - new kernel for the updated archlinux drivers)
Download: bzImage (5.6 MB - kernel linux 4.14.93 for PS4 with Baikal Southbridge and edited rev ID)
PS4 Gentoo Kernel Sources 5.3.7 with Baikal Chip Patches via Iguy0.jpg
 
:idea: Reminder: Those without a Verified Badge yet on Discord to access the private areas we recommend Joining Us! Why? The waiting process takes a week for new Members, and there's a lot we're unable to share on public forums including the latest PS4 PKG Games. 🏴‍☠️

Comments

crazyuser

Member
Contributor
Hi there. I own a ps4 pro console and found accidentally a solution for the black screen after booting the kernel. I use the initramfs and bzimage with psxitarch image file.

I start with the linux payload from psxitarch and after normal booting (after the text message welcome to arch linux) my screen goes total black. No combination with the keys ctrl f5 or ctrl f1 works.

At this moment i plug out the hdmi cable and then plug it in at the same input. Then with the combination of ctrl f5 and ctrl f1 I finally see the linux desktop.
 
:idea: Reminder: Those without a Verified Badge yet on Discord to access the private areas we recommend Joining Us! Why? The waiting process takes a week for new Members, and there's a lot we're unable to share on public forums including the latest PS4 PKG Games. 🏴‍☠️

mrtwinky

Senior Member
Contributor
@seanp2500 It could be that you are not only using a usb 2.0 but your probably using a normal 16G flash drive. My advice is to get a HDD or something that has high rpms.

Also some space if you want to do anything besides watching things on it. Format it to NFTS and use rufus. Launch the payload and it should load and start up by itself, if for some reason it doesnt start by itself put this command "resume-boot". It should start up.

Another thing that could have a problem is the model of your ps4. Some work and some don't. I can't tell you which models work or not. You will need to figure that out yourself.
 

seanp2500

Senior Member
Contributor
Verified
@mrtwinky yeah post is mad old. You were wrong about the usb thing. You were right about rufus. Wrong about nfts whatever that is lol. I know what you meant by the way.

Rufus does a reformat before burning the image anywho. What the problem had to do with was payload actually. Using a usb 2.0 flash drive actually works amazingly well for my purpose which was linmugen. The real problem became no sounds in linmugen. Sad face.

I guess this image does not support oss. Any ideas? As for why I could not boot I needed the right payload actually. Funny what the answers turn out to be right?
 

mrtwinky

Senior Member
Contributor
@seanp2500 To be honest I dont have a clue. Lol yeah. Also have you tried using the psxitarch payloads to make it work? I tried using all 3 payloads and all i get is black screen (I use the gentoo payload but that takes way to long compared to psxitarch)
 

Ahmed Jamal

Member
Contributor
@MODDEDWARFARE bro mirchoo updated gentoo drivers on repo kindly tell us how can we update mesa and lib drm through that files i readed the files. it contain mesa 20!!!!

plz upload a video or tell me in comment. waiting for your reply
 

dablo

Member
Contributor
hello.
I have successfully boot into the gentoo linux. but my wifi and bluetooth adapter are not working. I'm using psCUH-1206A 4 fat btw.
any idea how to fix the Bluetooth and the wifi adapter?
 

MikeyDee

Member
Contributor
Hi Guys, getting there almost. I have a Pro 7116b , I can now get to a rescue shell, but see this "Mounting /newroot The "root" variable is empty, set to false or zero but shouldnt be"

I go ahead and type "mount" doesnt look like any errors then run the exec install-psxitarch.sh

Trying to find the right USB error, I have tried the USB in all 3 USB ports on my Pro. Any help appreciated.

@ordenador71 ,
What steps did you use to get yours working.
 

Timonp40

Member
Contributor
according to this I installed on my ps4 and it works but I had problems by updating the linux system and mesa drivers

on my PS4 console I have Linux mint 19.3 installed and I had no problems updating the system, but there was a problem with the cursor, there was no visible configuration file, and its modification fixed the problem with the cursor
 

MikeyDee

Member
Contributor
Today, I managed to get linux installed and running on my 7116B Pro. Been using Linux for years in a previous job, so I know a bit of how it works and most of the commands.

When I run install-psxitarch.sh, I still got errors. Is I run, ls -al to show the list of files and find install-psxitarch.sh not in the directory.
I know most executables are in /bin folder, so I cd /bin , then ls -al again. I see the shell script and run again, using:
Code:
./install-psxitarch.sh
This time it installed, yippee. Still in /bin folder, I run the start-psxitarch.sh, and viola I have Arch Linux running of PS4 7116B.

First Observation is that the wifi works, but Ethernet does not. Ok no probs.

Note 1: I have tried this for a month at least, and now it is running, open a terminal , to check things, Run "uname -a" it shows a gentoo kernel not arch Linux as I thought it would be.

Note 2. After shutting down , and return to PS4 , then try Linux again, Nada. No matter which options, so far this is hit and miss, more miss than hit.

Will keep on plugging on

Thanks everyone

Update: you need the correct combination of files Period. (make multiple backups when you get the correct ones) I now have (on separate drives) Gentoo, Fedora 31, Linux mint and psxitarch working all on my Pro 711b.

Only One issue i found , no Ethernet , only wifi, buy hey that minor now, Thanks for all the great work.

If anyone can help me get the Ethernet working , that would be great.
 
Recent Articles
PS4 Webkit Bad_Hoist 6.72 Exploit Port WIP by Sleirsgoevy & 6.72 Dumps
Proceeding his PS4 ROP 8CC Port and the 7.02 PS4 Kernel Exploit (KEX) release, PlayStation 4 scene developer sleirsgoevy added a work-in-progress (WIP) port of the PS4 Webkit Bad_Hoist 6.XX...
DiRT 5, Vampire: The Masquerade & Werewolf: The Apocalypse PS5 Trailers
Following the PS5 hacking-themed Recompile Gameplay footage, today we have some new PlayStation 5 video game trailers for off-roader DiRT 5, Vampire: The Masquerade - Swansong and Werewolf: The...
Sony Reveals PlayStation Now Games for July, 2020
Today Sony revealed the latest additions to their PlayStation Now video game streaming service for the month of July, featuring Watch Dogs 2, Street Fighter V and Hello Neighbor. :cool: According...
PS4 Kernel Exploit (KEX) for 7.02 Firmware, Wait for Jailbreak Before Updating!
As promised last month, PlayStation 4 scene developer theflow0 just dropped the PS4 Kernel Exploit (KEX) for Firmware 7.02 and below which was patched by Sony in 7.50 PS4 OFW (Current OFW is 7.51)...
Top