Category PS4 Jailbreaking       Thread starter PSXHAX       Start date Jan 1, 2018 at 2:27 AM       28,164       59            
Finally it's happening... over a year ago fail0verflow revealed PS4 Linux on 4.05 Firmware and continued to school the PlayStation 4 scene on everything from Adieu to Kernel Dumping which ignited the 4.05 era of exploiting, jailbreaking and once again PS4 Linux followed by PS4 Linux Loader 4.55! :fire:

Many may recall seeing a demonstration from the Tencent Security Conference, and according to Rebug developer @Joonie early PS4 Linux Loader work was missing the now released 4.05 Kernel Exploit.

While many developers including @jocover have been working (405_linux_loader.bin - 21 KB) on a PS4 Linux Loader (GIT), PlayStation 4 developer @valentinbreiz (Twitter) who brought us the 4.05 PS4 Payload Sender last week was able to get PS4 Linux running on 4.05 with PS4-Linux-Loader.bin payload testing by @Darbness (Twitter) who shared a 4.05 PS4 Linux demo video below! :beer::beer:

Download: PS4-Linux-Loader-master.zip / ps4linux.rar (7.0 MB) / ps4linux.rar (Mirror) / PS4-Linux-Loader.bin (1.0 MB) / PS4Linux_Fedora.zip by fail0veflow (2.27 GB - Build Pass is 1 via @MrCarlesX) / GIT / Live Demo / PS4 Linux on Slim 4.05 Firmware by ecHs / PS4 Linux Loader 4.55

From the README.md, to quote: PS4 Linux Loader - A simple payload that lets you run Linux on your 4.05 PS4

WORKS! With IDC's exploit.

Hosted here for your use: http://darbness.com/ps4.

How to build

I use https://github.com/idc/ps4-payload-*** to compile it. You also need to compile https://github.com/fail0verflow/ps4-kexec and place 'kexec.bin' into this folder. Compile kexec with 'make CFLAG='-DPS4_4_05 -DKASLR -DNO_SYMTAB'.

How to use

You need a FAT32 formatted USB drive plugged in on any PS4's USB port with the following files on the root directory : bzImage and initramfs.cpio.gz. You can download them here.

Then you will need to send the payload (PS4-Linux-Loader.bin) to your PS4. For that go to your PS4 web browser, go to darbness.com/ps4 and send the payload to your PS4 using netcat or other.. (You can also use my tool: PS4 Payload Sender).

To do:
  • Fix ASLR (that causes a random successful boot)
  • Clean code
Credits and links

Thanks to 2much4u, Darbnes and jiangwei.

Useful links:
Spoiler: PS4 Linux Videos

Running Linux On 4.55 (PS4 Jailbreak)
Finally, here's some more PlayStation 4 Linux guides for those interested:
PS4 Linux on 4.05 is a Thing! Valentinbreiz Darbnes #Hello2018.jpg
 

Comments

seanp2500

Senior Member
Contributor
my own personal take from how I understand the ps4 is this should work on any ps4 4.05. I am very skeptical of users who claim this does not work. I think they have issues with how their USB devices where prepared.

So far myself I have had a failure rate of 3 out of 5 installs only Ubuntu 16.04 and and the fedora. So far only virtual box and rufus produced good discs. Fedora loaded auto but ubuntu had to be mounted.

Please also remember that I believe you need 2 usb discs one for kexic and the linux loader files and one for your actual install
 

Horst von Braak

Senior Member
Contributor
Hi,
I made a Stick with rufus (Fedora) and load the files from an fat32 externel HDD. The Screen turns after 20 sec to black and nothing goes on.

I got a CUH-2016b, do you run Linux on newer devices?
 

seanp2500

Senior Member
Contributor
no but i understand linux and I don't think it knows you have cuh or whatever. Keep in mind sometimes the exploit just fails to load for me AND I HAVE A WORKING MODEL. i Have proven and established that. I WOULD LOVE THE SCENE TO GIVE ME TEST PS4's but i only have a launch day fat so whatever was first model k. with that said.

have you tried using virtual box with ubuntu 14 to create usb? then mount using the tut here: How to Run PS4 Linux Ubuntu Guide with Video Demo

Have you tried this tut here: PS4 Linux Pre-configured Distro for Emulators & More from D-ecks

You sure you compiled kexic.bin and that it is on a separate hd from your linux installed usb? Along with the bz and gz files? Have you tried a different tv? I would set res as low as possible. My tv it work perfect but I imagine others will have issues.
 

seanp2500

Senior Member
Contributor
my friend please reread instructions if you did not compile kexic you will not load rescue dash to load linux partition big error and more than likely the issue...
 
Recent Articles
PS4 Waker SmartThings App Device Handler by Xtreme22886
In line with the PS4 Alexa, PyWakePS4 on BlueTooth, PS4 Imagemap and IP-Symcon PS4 projects comes a PS4 Waker SmartThings App Device Handler used to control the PlayStation 4 power on / off and...
PS5 Pro Model a Possibility According to Sony VP Masayasu Ito
Earlier this week PlayStation CEO Jim Ryan stated that Sony Has No Interest in Another Handheld, and in a related interview Executive VP of SIE Hardware Engineering and Operation Masayasu Ito...
Mednafen PlayStation 4 Emulator v0.3 Config Mod Update via Markus95
Following the Mednafen PS4 2-Players Config Mod and his recent N64 PS2 on PS4 Port Demo, developer @Markus95 (aka @Kus00095) shared via Twitter a PS4 Mednafen v0.3 configuration update featuring...
Final PlayStation State of Play for 2019 Next Week, No PS5 News Planned
Today Sony announced their final 2019 PlayStation State of Play Conference will take place next Tuesday, December 10th at 6:00am Pacific Time / 9:00am Eastern Time. ❄ Their previous PS State of...
Top